Technical Support Forum Index
Technical Support Forum
Access ChemAxon scientists and developers here. For registration and login issues contact website support.

Support Ticket System is replacing forum

This forum was converted into a searchable archive. You cannot add posts here any more. For support please use our new Ticket System.

Create your first ticket
Lone pairs in MarvinSketch
To watch this topic for replies  Register (enables digests) or give email address:
This topic is locked: you cannot edit posts or make replies.
Display posts from previous:   
    View previous topic :: View next topic    
Author Message
Sujatha

Joined: 24 Mar 2012
Posts: 3

View user's profile

Back to top
Link to postPosted: Sat May 12, 2012 3:20 pmPost subject: Lone pairs in MarvinSketch Reply with quote

I am able to add lone pairs to an atom. However, when I copy/paste to Word, the lone pairs do not get copy/pasted. What am I not doing correctly? Thanks.

- Sujatha

Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Sun May 13, 2012 8:00 amPost subject: Reply with quote

Dear Sujatha,

Could you give me more information please? What is the version number of Marvin Sketch you are using? With what kind of operation system? How do you want to copy your structure into Word (as an OLE object, or as an image (emf, png, etc.)?

Best Regards,

Efi

Sujatha

Joined: 24 Mar 2012
Posts: 3

View user's profile

Back to top
Link to postPosted: Tue May 15, 2012 12:35 amPost subject: Information requested about lone pairs Reply with quote

Efi,

Thanks for getting back to me. Here is the additional information you requested.

I am using Marvin 5.9.2. I am able to place lone pairs, for example on oxygen in THF. When I copy/paste this structure into MS Word asa png image, the lone pairs don't copy over. I am using a Mac - OS X 10.6.8

Thanks.

 

- Sujatha

Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Fri May 18, 2012 12:03 pmPost subject: Reply with quote

Hi Sujatha,


We are still thinking about what can cause this problem. Do you use option "copy as png"?

Efi

Rens

Joined: 20 Nov 2012
Posts: 7

View user's profile

Back to top
Link to postPosted: Fri Sep 06, 2013 10:37 amPost subject: Reply with quote

I'm having the same problem as the topic starter. I add the lone pairs in Marvinsketch(6.0.5), but as soon as I copy the drawing and paste it in MS Word 2011 on my mac(10.8.4), the lone pairs are gone. I tried to change it with copy as, but the quality of the JPG, PNG and BMP aren't nearly as good as the PDF option. But the lone pairs are visible, also the negative charge in the PDF hasn't a circle. 

Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Fri Sep 06, 2013 12:05 pmPost subject: Reply with quote

Thank you for reporting this bug on pdf. We try to fix this in verion 6.1.1. (Please be aware, you will have to set "Save load GUI settings"  on "Save/Load"  Tab of Preferences Dialog  (Edit menu).)

Rens

Joined: 20 Nov 2012
Posts: 7

View user's profile

Back to top
Link to postPosted: Fri Sep 06, 2013 12:14 pmPost subject: Reply with quote

I checked the save/load GUI settings, but still the same restult. When are you expecting to release version 6.1.1? 

I also noticed when I close MarvinSketch the setting to show the lone paires is undone.

I was just drawing and noticed the negative charge and the lone pair are on eachother. (see image)




 Filename: Schermafbeelding 2013-09-06 om 13.57.26.png    Filesize: 8.19 KB    Viewed: 21280 Time(s)
 Description:  
Schermafbeelding 2013-09-06 om 13.57.26.png
Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Fri Sep 06, 2013 1:40 pmPost subject: Reply with quote

6.1.1. is planned at the end of September.

Rens

Joined: 20 Nov 2012
Posts: 7

View user's profile

Back to top
Link to postPosted: Tue Oct 22, 2013 4:03 pmPost subject: Reply with quote

I just installed the new version 6.1.2, but the problem with lone pairs is still present. I checked the box in the Preferences menu. Exporting as JPG works, but the lines are less sharp.

Waqas

Joined: 22 Oct 2013
Posts: 2

View user's profile

Back to top
Link to postPosted: Tue Oct 22, 2013 4:11 pmPost subject: Cant copy / Paste 3d model in MS Word Reply with quote

Please tell me how to copy/paste this structure into MS Word asa png image. I am using Marvin 5.9.2. I am able to place lone pairs, for example on oxygen in THF. When I , the lone pairs don't copy over. I am using Windows 7 Ultimate x86.

Thank you very much.

________________________

Waqas Khan

Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Wed Oct 23, 2013 8:30 amPost subject: Reply with quote

renszo:

I do not understand it. I created the attached pdf with the demo applet on our website: http://www.chemaxon.com/marvin/examples/applets/sketch/embed.html  

could you double check please whether "Save/Load GUI settings(.MRV, .PDF formats)" is checked on Save/Load Tab  of Preferences panel.


waqaskhan:

This feature only works in Marvin version 6.1.2.





 Filename: lonepairs.pdf    Filesize: 60.02 KB    Downloaded: 309 Time(s)
 Description:  
Rens

Joined: 20 Nov 2012
Posts: 7

View user's profile

Back to top
Link to postPosted: Wed Oct 23, 2013 9:24 amPost subject: Reply with quote

I double checked and the setting is marked. I also tried the web applet, this also gave the same result. I'm working with mac osx 10.8.4, marvin 6.1.2 and pasting in microsoft word 14.3.8.

In the settings for marvinsketch I also checked show lone pairs as line and show charge in Circle.

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Sun Oct 27, 2013 3:02 pmPost subject: Reply with quote

Hi,

this seems to be a bug in the copy as PDF functionality which differs slightly from the export to PDF. As a workaround you can use the export to create the image from the structure, and include that one in your documents.

We are working on to fix this issue, and we will notify you about the fix in this topic.

Thank you for your patience in the mean time.

Best regards,
Istvan 

Rens

Joined: 20 Nov 2012
Posts: 7

View user's profile

Back to top
Link to postPosted: Mon Nov 25, 2013 9:41 amPost subject: Reply with quote

Any news on the fix already?

Another question that I have is, if it is possible to have an editable picture in Word on the Mac?

Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Fri Nov 29, 2013 3:20 pmPost subject: Reply with quote

I am afraid, I do not have good news. We could not fix this issue yet and currently there is no way to have editable picture in Word on Mac. (only the pdf copy paste between the Word and MSketch ).

Best regards,

Efi

Rens

Joined: 20 Nov 2012
Posts: 7

View user's profile

Back to top
Link to postPosted: Thu Jan 23, 2014 10:13 amPost subject: Reply with quote

How is the progress with the lone pair problem? 

I just found that if I manually put lone pairs in my molecule they do not get copied, automated lone pairs do get copied with in JPG or other format except PDF. 

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Fri Feb 21, 2014 6:14 pmPost subject: Reply with quote

Hi,

we are currently still not had the time to work on this due to higher priority issues, but it is close to the top of our list for now.

Unfortunatelly I can not give you an exact estimation, but according to our current plans and status we will be able to give you the planned release version of the fix within a few weeks (late next week the earliest).

Thank you for your patience in the mean time.

Regards,
Istvan 

Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Mon Mar 03, 2014 2:58 pmPost subject: Reply with quote

Hi,

the fix is targeted for Marvin version 6.3.1.

Best Regards,

Efi

Rens

Joined: 20 Nov 2012
Posts: 7

View user's profile

Back to top
Link to postPosted: Tue Mar 04, 2014 9:05 amPost subject: Reply with quote

I just tried if the problem still exists, to my surprise the lone pairs are copied over. But now the charges and the reaction arrows disappear. 

Eufrozina
ChemAxon personnel
Joined: 13 Dec 2010
Posts: 843

View user's profile

Back to top
Link to postPosted: Thu Mar 06, 2014 9:29 amPost subject: Reply with quote

Unfortunately, the bug still exist we fix it ASAP and keep you posted.

Efi

This topic is locked: you cannot edit posts or make replies.
Page 1 of 1


To watch this topic for replies   Register (enables digests) or give email address  
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum