Technical Support Forum Index
Technical Support Forum
Access ChemAxon scientists and developers here. For registration and login issues contact website support.

Support Ticket System is replacing forum

This forum was converted into a searchable archive. You cannot add posts here any more. For support please use our new Ticket System.

Create your first ticket
Issues with My Templates
To watch this topic for replies  Register (enables digests) or give email address:
This topic is locked: you cannot edit posts or make replies.
Display posts from previous:   
    View previous topic :: View next topic    
Author Message
Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Thu Oct 13, 2011 8:20 pmPost subject: Issues with My Templates Reply with quote

Hi,

I have some difficulties with My Templates, using the Sketch applet.

I used to be able to simply highlight a structure and drag it into the My Templates toolbar. But for some time now it doesn't works.

If I open the templates library manager (by selecting Insert -> Template Library), select My Templates, and try to drag a molecule structure from the main Sketch window to the empty space at the right side, nothing happens.

If I right-click on the structure and select "add to my templates", nothing happens.

I also do not see anything on the advanced template toolbar, but this may be because there are no structures to show. If I click on the Properties tab of My Templates, the "display on toolbar" box is checked.

 

Hoe can I reactivate the My Template feature?

I am using Marvin Sketch 5.5.1.0.

 

Thanks,

Ron Caspi

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Fri Oct 14, 2011 4:34 pmPost subject: Reply with quote

Hi Ron,

could you be a bit more specific on the used version of MarvinSketch? I tried the My Templates functionalities you mentioned, and all of them works with 5.5.1 on my workstation.

I use Windows 7, and 32-bit MarvinSketch in a desktop environment. Do you experience this issue with an applet, on a webpage, or with the desktop application? Which operating system do you have, and which version? The contents of the dialog under the Help>About MarvinSketch menu could be useful for me, to check what can cause the problem on your side.

Regards,
Istvan

Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Fri Oct 14, 2011 8:13 pmPost subject: Reply with quote

Dear Istvan,

Thank you for your prompt reply! I didn't expect such a trapid reply. Wonderful.

I am using the applet, which we call from our own software, Pathway Tools.

The applet opens in the web browser (I am using the latest build of Firefox, today it is 7.0.1). Running Windows 7 64-bit.

I attach a screen capture of the information window that Marvin Sketch pops up.

 

Ron




 Filename: about marvin.png    Filesize: 12.28 KB    Viewed: 11177 Time(s)
 Description:  
about marvin.png
Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Thu Oct 20, 2011 12:53 amPost subject: Reply with quote

Hi Istvan,

Did you have a chance to look into the problem using the applet? Can you reproduce the problem?


Ron

Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Thu Oct 20, 2011 1:33 amPost subject: Reply with quote

Professional support would be nice, of course, but unfortunately our software is free, and our project is funded by government grants, so there is no budget for such a support...

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Tue Oct 25, 2011 2:10 amPost subject: Reply with quote

Hi,

sorry for the very late answer, i was a bit overhelmed. Finally i can managed to reproduce the issue in my environment with MarvinSketch applet 5.5.1.0 with the given Firefox version, but with an earlier java. After understanding the issue, it seems it is not depending on a java or browser version, the issue is related to the My templates and user settings handling inside MarvinSketch applet.

The problem is that, when you open the Insert>Template Library menu, and tries to add a sturcture there by dragging, or thru menu, then the template library attempts to save the My template template set status into a file in the codebase, and it is impossible. After tries to save the contents, it refreshes the My templates, based on a file that is not exsits on the server, and connects the file to the My Templates template set. It remains empty, since the file does not exsits on the server, and can not be created.

So you can use My templates unless you open the Template Library dialog, and load then modify the My Templates template set. After modifying it, the My templates will be unavailable. I can reproduce this behaviour also with 5.6, and with the 5.7 beta.

Maybe it is not as a big issue - as i see - since the applet does not store the my templates in general, so the structures inside My templates are available only for one session. In my experience templates can be created and added to the template toolbar thru contectual menu, and by dragging the structure to the template toolbar. It is fully available and working in a dektop version with Template Library dialog also, and by configuration, the applet is able to load template toolbar elements from the server also.

So i file a bug report into our issue tracking system and we will fix this in a future release, i hope very soon. I just want to know, if this is working on your site the same way as i described? If it is different on your site, please give me a step by step description on how you try to use the My templates, that may help to further examine the issue.

Regards,
Istvan

Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Thu Oct 27, 2011 1:01 amPost subject: Reply with quote

Hi Istvan,

Thank you for your answer. I am glad you were able to reproduce it, and am eagerly waiting for a fix.

However, I am puzzled by one thing in your reply. You said:

"the applet does not store the my templates in general, so the structures inside My templates are available only for one session."

But with previous versions of Marvin I was able to store strucutres in My templates, and they remained there between sessions. I would only lose my template data upon upgrading to a new version of Marvin (which was unfortunate).

Are you sure that the current version can't store the personal templates between sessions? if so, it would be very useful to return that feature. We curate a lot of structures, and it is very handy to have templates for groups such as "coenzyme A", rather than create them again everyy session.

Cheers,

Ron

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Fri Oct 28, 2011 8:51 amPost subject: Reply with quote

Hi Ron,

Let me check it, if it has worked before then it is a bug, and in this case we will also fix this.

Regards,
Istvan

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Wed Nov 23, 2011 12:46 pmPost subject: Reply with quote

Hi Ron,

sorry for the long silence, i have filled in a bug report into our tracking system.

What i have found:

The old version does not display the my templates data itself in the applet, that i have added in the desktop version before opening the applet. From 5.6.0.0 the applet does not read the contents of the local mytemplates file as the previous versions, but deletes it, and that is an issue what we will fix, just as the issue i have found in 5.5.1.

If you managed to use the local mytemplates template set in an older version, then please give me the used version, and the html code where you have the applet embedded.

Best regards,
Istvan

Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Tue Nov 29, 2011 5:50 pmPost subject: Reply with quote

Hi Istvan,

Unfortunately, I don't remember any more which version used to save the my template data between sessions.

I do know that it hasn't been working for some time, so I am not surprised it didn't work in the last version.

I think it worked with 5.3.8, but I may be wrong.

Regarding your request for "the html code where you have the applet embedded", I will have to talk with the programmer who wrote it and see if he can provide that to you.

Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Tue Nov 29, 2011 9:21 pmPost subject: Reply with quote

Istvan,

I think this may be the html you were asking for: I just opened a compound in the applet (that's the CPD-13912 part) and copied the source file.

 

<html><head><title>Edit Molecular Structure of CPD-13912</title><script LANGUAGE="JavaScript">
function return_marvin_molfile () {
  var mol = document.JMSketch.getMol('mol');
  document.marvin_form.mol_output.value = mol;
  //for debugging:   alert(mol);
  document.marvin_form.submit;
}

function get_browser_window_height(){
  var frameHeight = 550;
  if (navigator.appName.indexOf('Microsoft')!=-1 && document.documentElement) { 
           frameHeight = document.documentElement['offsetHeight'];
          }
  else if (navigator.appName.indexOf('Microsoft')!=-1 && document.body) {
           frameHeight = document.body.offsetHeight;
          }
  else if (self.innerWidth) {
           frameHeight = self.innerHeight;
          }
  else if (document.documentElement && document.documentElement.clientWidth) {
           frameHeight = document.documentElement.clientHeight;
          }
  else if (document.body) {
           frameHeight = document.body.clientHeight;
          }
  // There needs to be some extra room available for the form submission controls.
  return frameHeight - 200;
}

function get_browser_window_width(){
  var frameWidth  = 900;
  if (navigator.appName.indexOf('Microsoft')!=-1 && document.documentElement) { 
           frameWidth  = document.documentElement['offsetWidth'];
          }
  else if (navigator.appName.indexOf('Microsoft')!=-1 && document.body) {
           frameWidth  = document.body.offsetWidth;
          }
  else if (self.innerWidth) {
           frameWidth  = self.innerWidth;
          }
  else if (document.documentElement && document.documentElement.clientWidth) {
           frameWidth  = document.documentElement.clientWidth;
          }
  else if (document.body) {
           frameWidth  = document.body.clientWidth;
          }
  return frameWidth;
}
</script></head><body><h3>CPD-13912 : 2-carboxy-L-threo-pentonate</h3><center><script LANGUAGE="JavaScript1.1" SRC="/marvin/marvin.js"></script><script LANGUAGE="JavaScript1.1"><!--
msketch_name = 'JMSketch';
msketch_begin('/marvin', get_browser_window_width(), get_browser_window_height());
msketch_param('autoscale', 'true');
msketch_param('legacy_lifecycle', 'false');
msketch_param('cacheMols', 'false');
msketch_param('mol', '/META/CPD-13912.mol');
msketch_param('downWedge', 'mdl');
msketch_end();
// -->
</script><br><font FACE="arial,helvetica,sans-serif"><a HREF="http://www.chemaxon.com/marvin/">Marvin JMSketch Editor</a></font><br>To use the editor, please enable Java and JavaScript in your WWW browser.</center><form METHOD="POST" NAME="marvin_form" ACTION="/META/marvin-accept-structure?CPD-13912" ONSUBMIT="return_marvin_molfile();"><br><input TYPE="hidden" NAME="mol_output"><input TYPE="submit" NAME="submit" VALUE="Submit"> Will write back the structure into frame <input TYPE="text" NAME="cpd_id" VALUE="CPD-13912"></form></body></html>
Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Wed Dec 07, 2011 1:47 amPost subject: Reply with quote

Hello Istvan,

Are any of these fixes included in 5.7?

Ron

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Fri Dec 09, 2011 11:04 amPost subject: Reply with quote

Hi,

sorry for the late reply, i have evaluated the problem, and found three different issue related to your problem. The solution is not as easy to create, and our tight schedule also prevent us to solve this as quickly as it seemed first.

We are keen on to fix it, but currently the fix is not ready, so we could not inculde it into any release yet.

I will inform you when we have the fixed released.

Thank you for your patience and sorry for the inconvenience.

Regards,
Istvan

Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Tue Feb 07, 2012 1:45 amPost subject: Reply with quote

Dear Istvan,

I hope you somehow survive the winter in Hungary. Sounds like it is pretty serious this year.

Any progress on these bugs?

 

Cheers,

Ron

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Tue Feb 14, 2012 4:10 pmPost subject: Reply with quote

Hi Ron,

unfortunatelly I do not have so good news on this, when we started to track this down, I tried to fix the issue, it started to became a bit larger task then we first taught and could not managed to crate a stable fix on this issue in 5.9 either.

The good news is for you is that it will be a top priority issue for 5.10 and we scheduled this fix to the early days of 5.10 development, so I am pretty sure it will be solved in 5.10.

Thank you for your patience.

About the winter here, yes there were some pretty cold days, but it was managable. Actually i like the cold weather so i almost enjoyed it.

Cheers,
Istvan

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Mon Jun 04, 2012 10:52 amPost subject: Reply with quote

Hi Ron,

I am glad to inform you that the issue is fixed in the 5.10 version of Marvin Applets.

Thank you for your report and patience, if you would like to try the 5.10 public beta, you can download it from here.

Best regards,
Istvan

Ron

Joined: 27 Sep 2004
Posts: 43

View user's profile

Back to top
Link to postPosted: Tue Jun 05, 2012 8:36 pmPost subject: Reply with quote

Istvan,

You did it!  I downloaded and installed the beta version, and indeed , creating your custom library is as simple as dragging a structure, and it appears to stay there when I restart the browser. Hurray! I have missed this feature greatly.

Thanks again.

Ron

István
ChemAxon personnel
Joined: 03 Dec 2007
Posts: 688

View user's profile

Back to top
Link to postPosted: Wed Jun 06, 2012 3:16 amPost subject: Reply with quote

Hi Ron,

I am glad to hear that the fix is working well, and thank you for testing it. The official 5.10 release is expected to be available for download within a week or so.

Regards,
Istvan

This topic is locked: you cannot edit posts or make replies.
Page 1 of 1


To watch this topic for replies   Register (enables digests) or give email address  
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum