Technical Support Forum Index
Technical Support Forum
Access ChemAxon scientists and developers here. For registration and login issues contact website support.

Support Ticket System is replacing forum

This forum was converted into a searchable archive. You cannot add posts here any more. For support please use our new Ticket System.

Create your first ticket
cxcalc output comma
To watch this topic for replies  Register (enables digests) or give email address:
This topic is locked: you cannot edit posts or make replies.
Display posts from previous:   
    View previous topic :: View next topic    
Author Message
Miguel

Joined: 22 Mar 2014
Posts: 7

View user's profile

Back to top
Link to postPosted: Thu Jan 28, 2016 1:04 amPost subject: cxcalc output comma Reply with quote

Is there a way to output the results from a cxcalc plugin with decimal separator '.' instead of ','? specifically from MASS and LOGP.

 

Thank you for your help

Miguel

Daniel
ChemAxon personnel
Joined: 22 Jan 2012
Posts: 315

View user's profile

Back to top
Link to postPosted: Thu Jan 28, 2016 3:18 pmPost subject: Reply with quote

Hi Miguel, 

The separator applied depends on your number formatting set in the operating system settings. In Windows you can change this in the Change the date, time, or number format > Additional settings window.

I hope this helps. 

Daniel

Miguel

Joined: 22 Mar 2014
Posts: 7

View user's profile

Back to top
Link to postPosted: Thu Jan 28, 2016 3:30 pmPost subject: Reply with quote

Hi Daniel thanks for your answer. My decimal separator is dot and Not comma. But it was comma when i installed the software. Could that be the reason? 

 

Thanks 

KR

Miguel 

Daniel
ChemAxon personnel
Joined: 22 Jan 2012
Posts: 315

View user's profile

Back to top
Link to postPosted: Tue Feb 02, 2016 11:03 amPost subject: Reply with quote

Hi, 

No, the software installation should not alter the system separator settings. If you have Windows operating system running on your machine, you can modify the formatting settings in the Region and Language window. 

Daniel

Miguel

Joined: 22 Mar 2014
Posts: 7

View user's profile

Back to top
Link to postPosted: Tue Feb 02, 2016 11:11 amPost subject: Reply with quote

Dear Daniel 

I already did but still the problem persists. It still outputs comma instead of dot. My regional preferences are set correctly. Is there any other option On the chemaxon suite where that's an option? 

Thanks 

Best 

Daniel
ChemAxon personnel
Joined: 22 Jan 2012
Posts: 315

View user's profile

Back to top
Link to postPosted: Wed Feb 03, 2016 1:51 pmPost subject: Reply with quote

Hi, 

No, there's no such option as setting separators are totally dependent on your operating system and should be done on your local machine. I could easily change the separators in my Win system as I described above, so I can't give you new ideas. Maybe you could share your system info. 

Daniel

Daniel
ChemAxon personnel
Joined: 22 Jan 2012
Posts: 315

View user's profile

Back to top
Link to postPosted: Thu Feb 04, 2016 11:09 amPost subject: Reply with quote

Hi again, 

Can you send us which version of cxcalc you use, and how? What type of shell command line tool do you use?

Thanks, 

Daniel

Miguel

Joined: 22 Mar 2014
Posts: 7

View user's profile

Back to top
Link to postPosted: Sun Feb 07, 2016 5:31 pmPost subject: Reply with quote

Dear Daniel,


Thank you for your help so far and sorry for the delayed answer. I attach a printscreen with my regional settings and another with cxcalc version.

 

The shell command was 

cxcalc D:\path\file.sdf -S -v acceptorcount -e false | cxcalc -S -v donorcount | cxcalc -S -v mass | cxcalc -o D:\path\test.sdf -S -v logp

the last screenshot has the output of these 4 fields - I just re-ran it after taking the printscreen of the regional settings and cxcalc version so nothing has changed on that regard.

 

Thank you

Best

Miguel

Daniel
ChemAxon personnel
Joined: 22 Jan 2012
Posts: 315

View user's profile

Back to top
Link to postPosted: Thu Feb 11, 2016 1:21 pmPost subject: Reply with quote

Hi Miguel, 

I'm sorry but I can't give you more help on this issue. I tested it on the version you use and it works for me. I can easily change the separator through the settings window. What I can suggest is to update to the latest release of the cxcalc. However, this is not be the cause of your problem. 

Daniel

Miguel

Joined: 22 Mar 2014
Posts: 7

View user's profile

Back to top
Link to postPosted: Thu Feb 11, 2016 1:57 pmPost subject: Reply with quote

Thank you for your efforts Daniel. I have found a way to work around it. My problem was that On importing to instant J chem it would Not recognize the numbers properly, so im doing a series of importing as text, exporting and processing with a statistics package to standardize it. 

 

Thanks

Best

Miguel 

This topic is locked: you cannot edit posts or make replies.
Page 1 of 1


To watch this topic for replies   Register (enables digests) or give email address  
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum