Import sdf into Jchem For , problem with Excel column format

User f48d010cc5

13-11-2012 14:20:13

Importing sdf into Jchem4Excel has caused some unwanted transformation. Despite the fact that the value was tagged as a String when importing, it was transformed as if it was a number.

Here are some examples of :

01E09 ==> 1000000000
01E10 ==> 10000000000
01E11 ==> 1E+11  

01E09 of course mean plate 01 and the well position

I suppose it is more an excel parameter to set rather than a Jchem For Excel issue. Nevertheless after trying different options, I did not manage to avoid the problem.

Many thanks, Vincent

ChemAxon bd13b5bd77

13-11-2012 14:28:00

Hi Vincent,


I think this is what Excel causes itself. Excel wants to be clever enough and convert the data.

We pass the data through as VARIANT. Please try to format the column before and after the import.

Let me check in the meantime if there is an option in Excel to force it as a text. I am aware that we have for date/time ...

I will be back to you.

Please let me know how about Excel column formatting in the meantime.




User b4e6494a5d

27-11-2012 14:53:50

If the column is preformatted as a text column before importing the SDF file then 01E09 etc will be imported correctly. The problem is you have to know beforehand which columns will be imported where so you can do the preformatting.

Normally in excel the use of an apostrophe before a value indicates a text field but this had no visible effect on the sdf import when I tried it under various conditions and all imported incorrectly

Hope this helps :-)

User f48d010cc5

27-11-2012 17:05:28

Yes flephal, you are right. One of my colleague gave me this trick a week ago and it works. At least we found a way but we still need to tinker the sdf file to be imported. Therefore I would prefer to set Excel correctly beforehand. I had had no time to go into depth in this problem which is first and foremost an Excel problem.

Many thanks Vincent