Problem with the last version 5.6.0

User f006038a17

09-11-2011 14:32:42


Today, I installed the last version of JChem Excel 5.6.0. No problem during the installation.

Opening excel was OK, along with editing new structures.

However, when I tried to open a file created with previous JChem Excel, 11 minutes were neccessary to open the file, while as the same file was opened in 10 seconds with the previous version 5.5.1.

Best regards

ChemAxon bd13b5bd77

09-11-2011 15:03:11

Hi Frederic,

is that file you work with/on public? If it is not confidential can we get it for reproducing the problem?

Is this problem occurs in case of all files you created with the previous version of the program?






User f006038a17

10-11-2011 07:48:37

Hi Viktor,


Unfortunately, this file is highly confidential.

However, I checked others files, and no problems with them...



ChemAxon bd13b5bd77

10-11-2011 08:04:37

Hmm, then can you please send some information about the file, not chemical but technical,

e.g. how many records in it (from molecule), does it contain large molecules? Size of the file?

How many records (moelcules) can be seen on the screen on 1 page?

Could you please check the __JChemExcelStructureSheet? How many molecules can be seen there?

Please check the number of rows. You can access structure sheet by Unhide over the worksheet selector...





User f006038a17

10-11-2011 16:54:06

Size of the file : 24 Mo

About 2757 structures in one sheet

4 to 5 structures can be seen on the screen

but the problem is likely in the "JChemExcelStructureSheet" with 5350 lines!!!

Previously, I had some problems with structures which were replaced by a message

"Structure record not found for hash", due to a mismatch between the JCSYSStructure(xxxx) and the JChemExcelStructureSheet

With the previous version, I used to remove the incorrect line into the JChemExcelStructureSheet, but now, it is protected. So How can I do to clean up the JChemExcelStructureSheet ?



ChemAxon bd13b5bd77

10-11-2011 17:13:45



is this the workbook being opened after 10 mins hanging?




User f006038a17

10-11-2011 17:35:49

I am sorry, but I don't understand your question.

I still need more than 10 min to open it. Moreover, this afternnon, I used the filter option of excel and I observed something strange, all the structures normally excluded by the filter were accumulated into the first cell of the column....


ChemAxon bd13b5bd77

10-11-2011 17:45:09

Which Ms Office version do you use?

User f006038a17

10-11-2011 17:56:14

MS Office Professional plus 2010 (32 bits)

ChemAxon bd13b5bd77

10-11-2011 18:10:34

The macro protection is against unprofessional macros like
referring to the worksheet in this manner:

Worksheets(1).Cell(2,4).Value = "" this might kill 1 record from our repository.

I think you can agree with this approach (macro protected workbook)

Sending you the solution to your mail address.

ChemAxon bd13b5bd77

10-11-2011 18:16:01

Thanks, I will check the filter problems on that environment.

User f006038a17

11-11-2011 06:51:32

Of course, I understand the utility to protect the workbook. I am a user of JChem excel since about 3 years now, and the quality of the software is regularly improved.

Few bugs happened but thanks to help us to fix them.


ChemAxon bd13b5bd77

11-11-2011 07:18:50

Thank you for the positive words, we try to do our best.

Between 5.4 and 5.5 we made a bigger code change,
it might have introduced some extra issues that should not have gone in the code normally.
Of course such a refactoring can cause problems short term, but longer term we think that

the change was good for the quality.

User f006038a17

14-11-2011 14:01:03

Dear Viktor,

I finally solved the problem. It appeared that when the JChem_Excel was updated, all the structures were duplicated as an image. Consequently, in each cell were superposed the structure resulting from the JChemStructureSheet along with an image of this structure. Of course, the size of the file was huge, due to the presence of about 2500 images. Moreover, the use of the filtration tool led to the accumulation of image at the top of the column.

After removing all the images, the size of the file came from 21 Mo to 4 Mo, and of course, it can now be opened in few seconds.

So problem is solved, but I have no idea what happened...

Thanks again for your help

All the best

ChemAxon bd13b5bd77

14-11-2011 16:01:39

Thank you for the useful information you gave us!

We try to investigate what might  have happened!