JCStandardizeStructure Problem?

User 8717ac71bd

11-08-2011 18:39:04

Hi All,

I'm having a problem using a formula that has worked for me in earlier versions of JChem for Excel (I can't remember exactly when it stopped working).  I am currently using the newest version with 32bit Excel 2007 SP2 on 64bit Windows 7.

The function JCStandardizeStructure(MOLCELL, "clean") no longer works and only returns "Error parsing function." in the cell.  Other commands work fine, for example, "removeexplicitH" works perfectly.

I prefer to use the standardize method over JC2DCleanStructure because I normally string multiple operations together.

Can someone please look into this for me?



(Attached is a screen shot of what happens.)

ChemAxon bd13b5bd77

12-08-2011 07:37:13

Dear David,


could you please send us this document in Excel format physically instead of the png?

Other question: have you tried this with other ChemAxon programs like Marvin?

Once you send us the test molecule we will check that in two different JChemExcel versions:

5.4 and 5.5 possibly.

Thank you,


ChemAxon 0e37943a96

16-08-2011 11:34:21

Hi David,


could you check your license file for Standardizer? It could happen that it is expired, but the function reports the wrong error. In the next version, it will correctly report the license error.

The reported function works well in our environments.

Best regards,


User 8717ac71bd

24-08-2011 13:59:04

Thanks for your help.  I think I worked it out to a license issue but will confirm on another machine.