JChem for excel install: functions "grey out" when

User 706ca29ee0

07-07-2010 03:00:03


I just installed JChem for Excel ( on a machine with Windows 7 Enterprise and Office 2007. The install went smoothly. The JChem tab loads, and the Jchem for Excel splash screen pops up when I click any button. However, the buttons all grey out after I click anything, and won't come back until I've reloaded Excel. (I haven't gotten any structures into the spreadsheet yet). I've attached a picture of the screen to this post.

I've got .net 4 on the system, and have tried manipulating the Add-ons options as suggested in some other threads on this forum. I've gotten this to work on my Windows XP system at work...

Thanks; any help would be appreciated.

Chris Levins

[email protected]


ChemAxon bd13b5bd77

07-07-2010 06:06:17

Dear Chris,

when the controls get into greyed out state means that "fatal" failure took place at boot up.
In many cases it means that .NET library cannot be loaded for any reason. IKVM -.NET framework incompatibility and so forth.

What you can do is to check event log in windows admin page and even better if you check the Document and Settings\Your User\Application Data\ChemAxon\JChem for Excel subfolder and look into logs

JCHEMforEXCEL_2010_07_06.jcxllog files and send us the problem listed in.





User 706ca29ee0

08-07-2010 01:40:57

Hi Viktor,

Thanks for getting back to me so quickly. The following is the log entry that occurs when I try to click on any of the buttons on JChem for Excel. At at glance it looks like a problem with the licencse file (I've got the academic licence). Thanks!


[email protected]


22:56:56 [1]ERROR JCHEMforEXCEL - Error number: {-2146233088((null))}
   Error source: {Microsoft.Practices.Unity}
   Error Description: {Resolution of the dependency failed, type = "ChemAxon.JChemExcel.IKVM.Licensing.IMarvinLicenseChecker", name = "". Exception message is: The current build operation (build key Build Key[ChemAxon.JChemExcel.IKVM.Licensing.MarvinLicenseChecker, null]) failed: Could not load file or assembly 'JChem, Version=, Culture=neutral, PublicKeyToken=d25ce09139c726a9' or one of its dependencies. The system cannot find the file specified. (Strategy type BuildPlanStrategy, index 3)}
22:56:56 [1]ERROR JCHEMforEXCEL - Error number: {-2146233088((null))}
   Error source: {JChemExcelProxy::OnRibbonAction}
   Error Description: {Problem occured while raising click event from ribbon! (Unable to init Shell therefore no communication channel could be set up between COM and Shell!)}

ChemAxon bd13b5bd77

08-07-2010 09:05:28

Dear Chris,

my suspecion is that your license might be okay the problem is rather related to some structural issues with the installation. Please check what Marvin, Marvin .NET or JChem .NET API have been installed on your computer?
(It is strange that the required dll cannot be loaded from Global Assembly Cache)


User f0836ccd32

08-10-2013 10:14:22

I have Microsoft Excel 2007 running on Windows XP and the box turns 'grey' when I try to click on the license file or any other JChem button.

I have tried uninstalling and re-installing JChem_For_Excel_6.1.0.688 for end users.

JChem.NET API is also present.

I have looked for the log file but I can't seem to find it.

Any help would be greatly appreciated,


ChemAxon bd13b5bd77

09-10-2013 08:59:10

Please try to increase the verbos level to 5:



And check if the log files get created with the current date/time.

If there is no message in the log e.g.:

10:10:11 [3]INFO JCHEMforEXCEL - FIRST LOG MESSAGE FROM Jchem4XL::CConnectProxy

then it means some of our addins have been disabled. You need to re-enable them.