Could not convert SMILES to structure

User 4f5abf766a

06-06-2010 01:24:18


Exception: System.Runtime.InteropServices.COMException
Message: 方法 '~' 作用于对象 '~' 失败
StackTrace:    at ChemAxon.JChemExcel.ExcelCOM.JChemExcelAdapterClass.BeginUpdate(SHEETINDEX& siSheetIndex)
   at ChemAxon.JChemExcel.Excel.BaseExcelApplicationAdapter.BeginUpdate(String workbookName, String worksheetName)
   at ChemAxon.JChemExcel.Excel.DrawingExcelApplicationAdapter.BeginUpdate(String workbookName, String worksheetName)
   at ChemAxon.JChemExcel.Actions.ConvertToStructureAction.ExecuteAsynchron()

ChemAxon bd13b5bd77

06-06-2010 07:59:16

Dear Qing,

please try to completely remove your previous version of Jchem4XL, and try to reinstall the new one you find on the download site. is the latest one.

Because from the error I cannot really interpret/see the error message.
My other thoguht is that we have code page issue - multi lingual support on kanji.

I will double check the issue on a kanji environment, could you please do us the favour to translate the error message from kanji to english.



User 4f5abf766a

06-06-2010 09:07:02

Thank you for your help! 

 The vesion i'm using is already the latest one, and the message "方法 '~' 作用于对象 '~' 失败" means "method~acting on object~failure".

ChemAxon bd13b5bd77

06-06-2010 20:16:57

Tried out our kanji test environment and everything works fine,

I could convert smiles to structure without getting any errors.

Kanji (IME) was set to

- JP
- CH
- ZH

in all cases the conversion was okey. The SMILES was CCCC.

Is not it imaginable your smiles contains specific characters?

Can you please send me the stuff you would like to convert to structure?

User 4f5abf766a

07-06-2010 01:29:11

The smiles I tried to convert is [H]C(=O)C1=CC=CC=C1

ChemAxon bd13b5bd77

07-06-2010 06:04:04

Do you think that the kanji I listed above is so much different from what you are using?

Could you please tell me what kanji setting you are using? Regional settings? Keyboard settings .... and so on.

User 4f5abf766a

07-06-2010 10:08:28

kanji was set to CH

ChemAxon bd13b5bd77

07-06-2010 16:20:20

Dear Qing,

Jchem4XL team tested your issue on a Japanese official environment on more than 1 instance.

The issue did not come. 

Sending you a screen shot for you to please sepcify your regional settings. Kanji input (IME) settings are all tested against CH fully.

Please see the screenshot attached. Please focus on the red rectangle I tried to highlight in the screenshot.
Which item from the list should be chosen to get closer to your issue?


User 4f5abf766a

08-06-2010 13:57:20

Thank you for your advice!

I have solved this problem  by installing the latest .NET Framework.

ChemAxon bd13b5bd77

08-06-2010 14:58:56

Good news, thanks. From the error message my suspecion was different but if the problem disappeared, then it is good. In Lots of cases incompatible frame work version causes strange errors.