Adding rows to an IJC database

User b701b293b4

29-06-2011 20:58:52

Try as I might I cannot figure out how to add rows to an existing table.

When I right-click on the localdb and try to import a file with the structure as SMILES, IJC tells me that the Structure field must be mapped or a merge field specified. (I tried to map the SMILES to Structure, but that is greyed out.) I don't want to merge, I want to add to the existing table.

When I read in the file from the ribbon, I get a new table--not what I want.

Note: the help is no help with this.

ChemAxon fa971619eb

29-06-2011 21:29:44

Hi  Yvonne,

it seems that you are wanting to import data from a file and add it to existing data, rather than as a new dataset?

If so, then you need to select the appropriate data tree (the child of the local db in the projects window) and right click on it. Then choose 'Import file into ...'

This will then allow you to import your file into that data (e.g. append to it). You will see options for how fields in your file should map to fields in the database. The options are quite complex because the possibilities at this stage are almost infinite, but essentially you have the option of handling each field from your file in one of three ways:
1. add to an existing field in the database (possibly mapping the name fo the field in the file to the name of the field in the database)
2. create a new field
3. ignore.

Hopefully this makes some sense, though please ask if anything isn't clear. We can follow up in forum, or offline as needed.


User b701b293b4

29-06-2011 21:50:12

Yes, I want to add more rows to an existing table--new biological data on newly synthesized designed compounds.

When I right-click on the appropriate table and try to import using "Import file into existing entity", I get the message that the Structure field in the database is invalid. and won't go further. "Structure field must be mapped or a merge field specified" I don't want to merge, I want to add.

Could the problem be that the file to import has structures as SMILES?

ChemAxon e189db4705

29-06-2011 23:21:58


I tried to map the SMILES to Structure, but that is greyed out

I guess the problem might be that SMILES is already added somehow to "Fields in database" (right list) as a new field? Could you try to find SMILES in the Fields in database (maybe it's already mapped or added as new), select it in right list and press Remove button.

Then select SMILES in "Fields in file" (left list) and also Structure in "Fields in database" (right list). Then press Map button (see screenshot).