Loss of database access after software upgrade

User e05b1833aa

12-05-2011 11:54:48


I just upgraded to IJC 5.5.Table regeneration worked for all my databases, except one. Here IJC complains (see image) that it cannot regenerate tables because the user supposedly has insufficient rights. However, I am 100% convinced that the user has full administration rights, since this account is the same for all my databases, and it worked without any problem for this particular database before upgrading the software.

How do I regain access to my database?

ChemAxon fa971619eb

12-05-2011 12:30:43


The error is saying that the user you have logged in as does not have ROLE_ADMIN and ROLE_EDIT_SCHEMA. You need both of these roles.

I think there are these possible routes to fixing this.

1.Try connecting as a user that does have these roles, assuming you have one. If not...

2. Try connecting with the old version of IJC and then edit the security settings to add those roles. I'm not sure if you will be able to connect wih old version, but it might work. If not...

3. Depending on the type of security you are using you migth be able to add the roles directly in the database. Look at the IJC_SECURITY_AUTHORITIES table and add the missing role(s) to the corresponding user. If not ...

4. Clear the security configuration completely by deleting the appropritate row from the IJC_SECURITY_INFO table. This will completely remove your security settings ffor the IJC database, and once you have upgraded you can add the security settings back.

The last of thse will definitely work, but try them in the order suggested.


User e05b1833aa

12-05-2011 12:51:34


Just to make things clear, the database in question is mySQL-based.

Suggestion 2. works, but there I can see that the security settings for the account in question are sufficient, i.e. ROLE_ADMIN, ROLE_EDIT_DATA, ROLE_EDIT_SCHEMA, and ROLE_USER are granted. Also the default admin/admin combination still works under 5.4, but not under 5.5.

This latter fact particularly worries me and makes me reluctant to proceed with 3 or 4, because I am concerned that I will completely loose access, even in IJC 5.4.


ChemAxon e189db4705

12-05-2011 16:34:46


can you please send us the relevant part of ijc log file? Menu View -> Instant JChem log file. There should be at least info what role (DDL editor or ADMIN) is wrong.

Thank you.


User e05b1833aa

13-05-2011 07:19:05

Hi Petr,

A restart of IJC appears to have fixed the problem, now I can access the database again and could succesfully upgrade.