Exported xls jpeg images not sortable

User c29d691f4a

05-01-2011 18:17:12


  I've exported my project to .xls with jpeg images for structures.  When I sort the spreadsheet's columns, the images do not sort with their respective rows.  It appears the images are too big for excel to recognize them as being "in" the cell.  If I resize a single image and resort, it will move, but none of the others.  If I try and resize the row or column, the image conforms to the new cell size.  All of the exported images are designated to move and size with cells (see attached).  Any suggestions other than manually changing each image's sizing property? 

Thanks for your time.




Instant JChem Version: 5.3.4 (build: 100615)
JChem Version:
JChem Table Version: 5030300
Marvin Version:
5.3.4 (build date: 2010-06-15)
Java: 1.6.0_18; Java
HotSpot(TM) Client VM 16.0-b13
System: Windows 7 version 6.1
running on x86; Cp1252; en_US (instantjchem)
NetBeans build:

Microsoft Excel Version: 2007 SP2


ChemAxon fa971619eb

08-01-2011 14:27:42


Handling images has always been a problem in Excel. Images have typically had to be positioned at the same place as the cell, but really have no association with the cell itself, so when you sort and resize the cells the images no longer correspond. This was the major limitation of old versions of ISIS for Excel and Accord for Excel.

The current IJC export also hadles images in this way, and is not really suitable for advanced analysis.

If you do want to do serious work in Excel I would suggest using JChem4Excel, which has much more sophisticated strtucture display (the structures really are associated with the cells and behave as expected).

I'm not sure about the dialog you show. I'm not a big user of Excel and heven't seen this. it seems like an option in recent Excel versions. I will ask for mroe input from our Excel experts.

One final thing, I notive you are using IJC 5.3.4. This is quite and old version. You can update to 5.3.8 using the update centre, and 5.4 will be released very soon, though you will need to re-install to use this.