Importing Data with IUPAC Name and Smiles

User 7b0ee04e66

02-12-2010 14:56:12

Good afternoon

I have a text file (tab delimited) and the first row contains the column names, including IUPAC Name and Smiles.

When I import it into IJC (local database), the IUPAC Name is automatically mapped to Structure, but I want the Smiles to be mapped to Structure

I edit the Mapping, but I am then unable to add the IUPAC Name as a normal text column, 'Add' is always greyed out.

I am currently using version 5.3.8, but have also found the same issue with the latest 5.4 beta 1 version.




ChemAxon fa971619eb

02-12-2010 19:19:12

This is a bit bizarre. I see the same but the other way round. I get the smiles handled as structure and the name as the secondary field. I'm not sure why this happens, but I think we can fix it, but it needs a bit of testing.

In the meantime, I think this might do the trick:

Disable your name to structure license. That way the names won't be recognised as structures and there should be no dispute over what is the structure field.


User 7b0ee04e66

03-12-2010 08:45:20

Hi Tim

Thanks for the tip

I had a similar thing happening to me again last night, but this time (different set of columns) , it picked up CAS_Number and matched it to the Structure. Could the structure be mapped to the first String column in the file ?



ChemAxon fa971619eb

07-12-2010 15:19:58

I thought it was something like that, but I couldn't quite work it out.

Anyway, I applied a fix to the problem with the field mapping so that you should be able to switch between the candidate structure fields even if the wrong one is chosen by default.

The fix will be available in the next beta 3 release.