RDF import problem

User e911fe03b4

22-02-2010 12:13:49


I tried to import an RDF file which were created with Reactor. It's not recognized any field or data in RDF file.
I also tried with Tools -> Chemistry -> RDF import but I got the following error message:
    at java.util.LinkedHashMap$LinkedHashIterator.nextEntry(Unknown Source)
    at java.util.LinkedHashMap$KeyIterator.next(Unknown Source)
    at com.im.ijc.io.rdfimport.TemplateBuilder.writeDataTree(TemplateBuilder.java:209)
    at com.im.ijc.io.rdfimport.TemplateBuilder.createTemplate(TemplateBuilder.java:343)
    at com.im.ijc.io.rdfimport.wizard.RdfimportWizardIterator$TemplateBuilderRunner.buildTemplate(RdfimportWizardIterator.java:321)
    at com.im.ijc.io.rdfimport.wizard.RdfimportWizardIterator.createTemplate(RdfimportWizardIterator.java:202)
    at com.im.ijc.io.rdfimport.wizard.RdfimportWizardIterator.instantiate(RdfimportWizardIterator.java:178)
    at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1527)
    at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1481)
    at org.openide.WizardDescriptor.access$1700(WizardDescriptor.java:127)
    at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:2052)
    at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:577)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1030)

Interestingly IJC 2.4.1 is working this function.(with same rdf file)
I use IJC Version: 3.0.4 (build: 091023) and Java: 1.6.0_13 on Windows OS.

Could you give any suggestion on this issue?


ChemAxon fa971619eb

22-02-2010 14:00:33

This appears to be  an issue with version of Marvin that is included in IJC 3.0.4.

It seems to be fixed in the version of IJC that is about to be released. If you want to try it out you can so so here: https://www.chemaxon.com/download/instant-jchem-development-version/ />Otherwise the new release should be out this week.

Use the standard import, not the RDF import as this is non-hierarchical
data and can be imported using the standard import. If you do use the RDF import then make sure you select the "Treat
as SDF (non-hierarchical)" option when you generate the template.

If you still have problems can you please supply us with a small sample file.


User e911fe03b4

22-02-2010 14:51:46

Dear Tim,

Firstly I used the standard importing. I attached screenshots and you can see IJC can't recognize any details of RD file. This is very simple RD file which is output file of the Reactor. In any case I'm going to try the development version out as soon as possible.



ChemAxon fa971619eb

22-02-2010 15:02:00

Yes, it is not working in 3.0.4 (as you describe). Try the dev version and it should work OK.


User e911fe03b4

22-02-2010 15:25:20

I tested the dev version and it's working.