Copy and paste structures from Chemdraw on MacOSX

User 596f3ef229

03-05-2009 11:19:50

We are running the JWS version of IJC and mac users are reporting that they cannot copy and paste structures into the structure drawing part of IJC.

I did a test on a user machine - it was running the latest mac java and I tried to copy a chemdraw structure and paste into IJC - no dice. I tried "copy as smiles" from Chemdraw and it also would not paste. I paste the clipboard into a text editor and the smiles string pasted fine.

So it seems the clipboard contains the smiles, but for some reason it won't paste into jchem. Any ideas on what is causing this?

ChemAxon fa971619eb

03-05-2009 12:27:03

I'm not really sure what is the problem here. We'll try to test with ChemDraw and see if we can reproduce this.

Does pasting some plain text in smiles format work? e.g paste this: c1ccccc1



User 596f3ef229

05-05-2009 00:55:34

ok just did a test on a mac running MacOS 10.5.6 with all current software updates.


Typed "C1CCCCC1" into the text editor, selected copy, attempted to paste into IJC structure drawing applet - did not work. Opened the stickies app, pasted into a note just fine.


Opened the mac "console" and found the following clipboard exception in the logs:

5/05/09 10:42:04 AM java[208] *** CPerformer: ignoring exception '*** -[NSCFArray insertObject:atIndex:]: attempt to insert nil' raised during perform of selector '_nativeGetTypes:' on target '<CClipboard: 0x12cc90>' with args '(


"java -version" in a terminal window reports:

java version "1.5.0_16"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)
Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode, sharing)


The system software update logs report the latest installed java update as "Java for MacOS X 10.5 Update 3, version 1.0" - not sure if that is the latest or not but it says there are no other updates available.



tried to paste the smiles into other fields of the IJC query window. It does not work. Seems the problem is not specific to the structure applet.

User 052e705023

05-05-2009 12:11:19

This seems to be a problem of JSW (WebStart) version of IJC. It works fine in regular installed application. It is probably caused by insufficient permissions. We are going to look at the bug.

User 596f3ef229

19-04-2010 23:31:19

Sorry to drag this thread back up again - was there a solution for the problem of not being able to copy-and-paste into the java webstart version of IJC from mac? We are still seeing the same behaviour.

I guess if the full mac version is OK with copy-and-paste, maybe we could manually install that on our macs and simply open the shared project?

EDIT: I just realised we are still running IJC JWS 3.0.4 so I will update to 5.3.1 and see how that goes.

ChemAxon 49d153c1b2

20-04-2010 06:43:19

Unfortunately we were not able to find a proper solution for this issue. Known workarounds are:

Sorry for inconvenience.