Java.lang.Nullpointerexception error saving files

User 48ef08c378

28-11-2008 06:39:15

Thilagavathi Ramasamy wrote:


I am using Instant Jchem for removing the duplicates from the large

database. When i tried to save the file it gave the following error

A java.lang.NullPointerException exception has occurred.

Click Show Details or see the messages.log file located in

your /home/thilagavathi/.instantjchem/ws_www.chemaxon.com_stable/var/log


When i clicked show details following message appears











at org.openide.WizardDescriptor.updateState(

at org.openide.WizardDescriptor.initialize(

at org.openide.NotifyDescriptor.getterCalled(

at org.openide.DialogDescriptor.isModal(






[catch] at org.openide.util.Mutex$

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at Source)


I am not able to save any of the files. Could you please help me how to

debug this problem?

Thanks, Thilagavathi

ChemAxon fa971619eb

28-11-2008 08:28:47

Sorry, I am unable to reproduce this.

Could you explain a bit more what you are doing.

I assume you have imported data into a JChem structure entity (table) with the duplicate filtering option turned on and are now trying to export those imported structures to a file in InChi format?

Is so I have just tried doing this export in the latest IJC and it works OK.

Could you explain if your are doing anything different?

Also, could you confirm what version of IJC you are using.

Use the Help -> About box and copy and paste the information from there.

Many thanks


ChemAxon fa971619eb

28-11-2008 09:28:30

On further investigation we have identified how this can happen.

It looks like you are exporting from the entity in the schema editor, and there is the bug you describe if you do this. We will fix this.

There is a simple workaround.

You can export from the data tree in the project explorer instead.

This was almost certainly created when you imported your data, bu tit if is nott there you can create it usign the New Data Tree option from the right click menu of the schema node, adn then select the appropriate entity.

Once you have the data tree use the Export to file.. option from its right click menu.



ChemAxon fa971619eb

26-12-2008 09:39:53

This problem is now fixed in IJC 2.4.1. Export can be used from the schema editor as well as from the various elements in the project explorer, or from any form or grid view.