Java problem when querying an Instant JChem database

User 1961514564

12-03-2008 15:47:08


The versions used are :

Instant JChem Version: 2.2.1 (build: 080214) JChem Version: 3.2.12 Marvin Version: 4.1.14 (build date: 2007-12-11) Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b05.

When I query an Instant JChemreaction database (6743 reactions), I do no retrieve any answer if I specify that a bond has the status "make/break". Then the java machine cannot be stopped and its used memory grows up to 150 Mo. This process must be killed within the Task Manager.

If I don't specify any status for a given bond, the queries proceed well.

Thank for your help

ChemAxon fa971619eb

12-03-2008 19:26:21

I tried this with a simple example and it worked without problems.

Are you able to provide more information (e.g the data file and the query)?


User 1961514564

13-03-2008 07:54:00

That's probably the data file that causes some crashes when I query by substructure with a cyclohexane having a "make/break" bond.

I tested another rd file and the above query run well.

I attached to you the problematic rd file and I would be pleased if you could detect any fault.

Thank for your help


User 1961514564

13-03-2008 14:16:15

hello Tim,

I worked again with the initial reaction data file (6743 reactions) and I noticed that I could query the InstantJchem database with a query containing a six-membered ring, a nitrogen atom and a "make:break" bond.

On the opposite, the java machine crashes when I query a six-membered ring, all carbon atoms and a "make:break" bond.

Where is the bug ?

Thank you for your help

ChemAxon a3d59b832c

13-03-2008 15:14:40


Thank you for the test data. We could reproduce the problem, and will investigate it.


ChemAxon 42004978e8

23-04-2008 13:32:58


We improved the performance, the search is executed, but we have yet to

speed up some slow calculations.

The improvements are available in version 5.0.3.


User 1961514564

13-05-2008 08:11:35

Thank you for tour help.

I use now the new version 2.3 of InstantJChem and I've got no more problems when querying a substructure search including bond attributes such as Make/Break.