Upgrade difficulties

User 259df256ea

17-01-2008 23:49:46

We've just updated most of our users to 2.2 on both Mac and PC platforms, and have been generally successful. On one of out PCs, the upgrade was successful, but an error was generated upon initial launch that indicated a number of modules or libraries could not be found. We upgraded this computer to Java 5.6, and now IJC 2.2 launches with no difficulty (no error dialogue), but the the tab 'Miscellaneous' under the 'Options' window is blank, so there is no way to enter a license key or connect to a remote database (and no way to tell you what the error actually said).

We've tried a fresh install of IJC 2.2 several times, but the problem remains the same.

Any ideas?

ChemAxon e189db4705

18-01-2008 00:31:25

If you don't see the Misc tab content under options, it probably means that some modules were not installed properly and IJC installation is corrupted. Something wrong happened during update (that's what the error dialog was saying). There are some possibilities how to fix the installation, but I think the easiest way is:

1. find your IJC userdir and rename it - on Windows you should have it somewhere like: "c:\Documents and Settings\yourlogin\Application Data\.instantjchem\ijc_2_2" - rename this folder for example to "ijc_2_2.bak"

2. uninstall previous IJC version

3. install new IJC 2.2 using standard installer.

To analyse what the problem is it would help us to see if there are any errors reported in messages.log file. If you still have IJC running you can find it under View menu -> InstantJchem log file or on disk it should be under c:\Documents and Settings\yourlogin\Application Data\.instantjchem\ijc_2_2\var\log\messages.log. thank you.

User 259df256ea

18-01-2008 01:30:01

Thanks. That fixed it.