rdf import problem

User 1961514564

06-09-2007 07:46:11


I'm trying to import an RDF file with 743 reactions which were collected from a ISIS database. I get the following error:

java.lang.NumberFormatException: For input string: "4.540000000000000e+001 - 4.700000000000000e+001"

at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)

at java.lang.Float.parseFloat(Unknown Source)

at com.im.df.impl.db.convert.FloatConvertor.convert(FloatConvertor.java:38)

at com.im.ijc.core.io.quickimport.QuickImportWizardIterator.loadData(QuickImportWizardIterator.java:677)

at com.im.ijc.core.io.quickimport.QuickImportWizardIterator.access$100(QuickImportWizardIterator.java:89)

at com.im.ijc.core.io.quickimport.QuickImportWizardIterator$2.run(QuickImportWizardIterator.java:521)

at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:539)

[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:964)

I work with InstantJChem2.0 on a Windows XP SP2 station (1 Gb RAM).

Thanks for reply


ChemAxon fa971619eb

06-09-2007 08:08:52

That appears to be being casued by trying to import that value into a decimal number (float) field. As you will see the value specifies a range and so is not a valid number and so will have to be handled as a text field (we plan to support range fields in a future version of IJC)

Maybe the initail values for that field were valid numbers, but this particular value came relatively late in the file (only the begining of the file is usually read).

To solve this either set the field type manually to Text on the step where you can specify the field parameters, or parse the completely by clicking on the 'Read more' button on the previous step (setting the number of records to read to zero will cause the whole file to be parsed which should ensure the correct settings).

Hope this helps.


User 1961514564

06-09-2007 08:22:55

Thanks for your quick reply,

I tried both solutions you suggested. Only the first one run in my case and it succeeded in reaching the full rdf import.

Have a fine day