Chemical Terms Field

User 17ae043cc4

05-05-2007 03:53:29


I just started to use Instant JChem. One of the problems that I have run into

is that the field does not seem to properly update on my system. I tried to use match of different types for several different items and did not get a result. I tried smiles and it then populated that field plus the other that I had already entered. I then tried to replicate my success and have not been able to do so. I have updated IJC today and still got the same result.

The columns seem remain completely blank. I also tried to replicate the one's that is mysteriously filled in when I did the smiles and it leaves those blank although I know there should be values and the system has calculated values. I do see the % calculated window go to 100. I do not see any output message.

I had some one replicate on another machine and their machine calculated the values immediately.

Any thoughts on what I may need to change?


ChemAxon fa971619eb

05-05-2007 07:07:16

Hi Darcy,

I think what you are describing is a display update bug that we are aware of.

In the current 2.0 alpha version we do have a bug that results in the currently displayed values not being immediately updated once a chem terms calculation has finished. We are working on fixing this bug, but in the meantime if you close the DB and reconnect to it (or restart IJC) you should see the correct data.


User 17ae043cc4

05-05-2007 13:45:52

Thanks for the prompt reply. Unfortunately closing the database did not help nor did restarting the application. The columns remained blank.

Is there any other suggestion that might help?


ChemAxon fa971619eb

05-05-2007 14:02:23

Please could you describe the chemical terms expressions you are using.


User 17ae043cc4

05-05-2007 14:54:24

As I mentioned before, I tried






I know that the smiles and match should work because I actually ahve

the results still from my earlier attempt. However when I tried the exact same expression again the new columns are empty. I would expect even ringCount to at least give me a 0 but it is blank.

Please see the attached screenshot.

The far right column was attempt to reproduce New Chemical Terms 2. It is completely empty.


ChemAxon fa971619eb

05-05-2007 16:44:56

I notice that your structures contain ANY atoms, and you must be using a table type of ANY STRUCTURES for these. When your structure contains a query atom (e.g ANY) many of the descriptors cannot be calculated and so you get an empty result.

All those expressions with the demo pubchem data that comes with IJC and they all seem to work OK. these don't contain query atoms.

Can you try with that same data to see if it works OK (create a new project with demo data).

User 17ae043cc4

05-05-2007 18:32:47


Here's the issue. I put in the "EXACT" same query and I have results in one column (although it was delayed) and no results in the other.

If a query does not work because of the data then it would presumably NEVER work. However we do KNOW that is will work because it has worked on 20 minutes before against the EXACT same table with the EXACT same query.


User 17ae043cc4

05-05-2007 18:46:22

Yes, the sample data worked fine as expected with molecules. Unfortunately our research is focused on functional groups not entire molecules. When we do the import the system selects any. Again it did work once and we have another colleague who did not run into any of the problems importing the exact same file. Are there different import options we need to consider to get consistent results?

ChemAxon fa971619eb

05-05-2007 20:24:27

When you import data IJC makes a guess about the best table type based on the contents of the file.

For however many records in the file you have read it sets the JChem table type as follows:

1. If only "normal" structures have been found then table type is set to MOLECULES

2. If only reactions have been found then table type is set to REACTIONS.

S. If any any query atoms are found, or if both "normal" structures and reactions are found then the type is set to ANY STRUCTURES.

What is found may be dependent on how may records you have read. Normaly first few will give the correct result, but if you want to be absolutely sure then read the whole file (set the Read more value to zero and press the button).

You can over-ride the table type by clicking on the options button (...) next to the table details selector. But of course, if you over-ride this manually you need to make sure you make a sensible choice.


User 17ae043cc4

05-05-2007 20:35:42

So based on what you said, no there are not other import options that we should consider for importing a file of functional groups.

Also changing from ANY is not an option for us to resolve the problem that my system will not update with the new fields.

Let me know if there are other suggestions.

Thanks for taking the time so far. Hopefully if it is a bug it will be resolved in future versions it seemed as if it might be helpful but right now it does not work for us.



User 17ae043cc4

05-05-2007 21:29:33

I did some additional experiments and I have found some clues about the behavior but no consistent answers. I have found that if there is a column that has not values then any attempt to do additional columns will also be blank until the blank column is removed.

I wish I could find some consistency. In one of the samples I have, I removed the blank column and then was able to add match("*S*") column successfully. I added a couple of other columns then it stopped working. I think I tried the ringCount() (perhaps it only works with molecules). It came up blank. I then deleted that column and I tried the smiles function which worked fine. Played some more with that file and eventually it ceased to generate any new column with data. Meanwhile a second copy of the same data continued to add columns during the same session.

There is some weird going on perhaps with the data cleanup after deletes. I also noticed that in some session the progress scroll would start then end suddenly. I would get a "New chemical calculation successfully created" but it was NOT. If nothing else I think it would be appropriate to have a different messages for

1. Inappropriate application of the term such as when I tried ringCount()

2. The system fails to add any value when it should as when I tried match("*S*") and all values where blank.

3. When the system is actually successful such as when I tried match("*S*") and I got values of 0 and 1's. Remember this is in the exact same table as in example 2.

Just having those differing error messages would seem appropriate.

Let me know if having a sample file or dataset to replicate the problems would help.


ChemAxon fa971619eb

07-05-2007 13:34:52

The problem is caused by the chemical terms expression that is failing. When this happens it prevents values being generated for the entire row. We will work on improving this and find a better way to report errors.

In the meantime you should remove the bad expressions and then add a new chem terms field to cause regeneration of the values.


User 17ae043cc4

07-05-2007 13:47:06

I'm confused by the response. If it works sometimes against the same set of data, doesn't that mean the expression is fine? If the expression is bad, shouldn't it always fail?


ChemAxon fa971619eb

07-05-2007 14:12:26

The caclulations will work whilst you have valid chemical terms expressions. When you add one that is invalid (e.g ringCount() when your structure contains query atoms) it will then prevent calculation of all values for that row. It is this aspect that we need to improve. One bad calcuation should not prevent the other good ones from completing.

That is why you initially see values being calculated, and then they disappear.

User 17ae043cc4

07-05-2007 15:48:41

Sorry to harp on this. But the situation is WORSE. If I enter a valid expression it will simply NOT work.

I started a new database. Entered only valid expression. In fact I decided to keep entering the smiles expression. I know that it is VALID because all of the values where calculated. When I entered SMILES a third time it simply FAILED. I never entered an INVALID expression so while you may have a problem with invalid expression, the problem I am having occurs also when you enter only valid expression.

I have attached a screen print.

Thanks for all of your time. I'm sorry that the tool is not working properly on my system. Based on your comments and the behavior this is a new issue. I assume it must be something with my system as you don't seem to have it with other users.

Alas, I was really looking forward to using it. I am concerned that IJC is meant to displace some of your other line command tools in future development. We may have to find a different platform.

Thanks again.


ChemAxon e189db4705

07-05-2007 16:05:41

I know you mentioned it before, but just to be sure: IJC restart doesn't help? After IJC restart you still see empty cells in "Smiles 4" column?

I just want to ensure this is not a bug I just fixed yesterday, it had very similar symptoms (also empty cells after adding CT field).



User 17ae043cc4

07-05-2007 16:31:14

I'm glad you wrote again. You are CORRECT. This time the restart did impact the viewing. I closed and restarted and this time the field displayed. So now I get it. I was encountering two separate issues with different solutions:

1. Valid expression Update failing - with a restart being the solution

2. Invalid expression - updating failing - eliminate the invalid column and then try to restart.

Thanks again for helping me clarify how to resolve the issues.

Let me know when your updates are available.


ChemAxon fa971619eb

07-05-2007 18:48:21

We expect to have an update for problem #1 very soon (this week).

#2 will take longer to fix. For now you will need to ensure that you specify a valid chemical terms expression.