option for checking duplicates

User 5208065412

01-03-2007 12:00:06


I wanted to know is there any option for checking duplicates in instant Jchem


ChemAxon fa971619eb

01-03-2007 12:17:33

Yes, this can be done in 2 ways.

If you have a set of structures that contain duplicates then you can import these into a JChem table which does not allow duplicates. When a duplicate is found that structure is not imported.

To do this set the 'Duplicate filtering' setting when you create the JChem table. This is available when you create a new table:


or when you use the Standard import wizard (not the quick import)


The second approach that might be useful is the ability to compare two structure tables for identical (or similar) structures. To do this use the Overlap analysis wizard:


I hope this helps.


User 2d31d11602

13-03-2007 09:47:33


I checked the « duplicates removal » option when importing sd files into a JChem table. However, I would like to remove duplicates without taking stereochemistry into account (I attached some examples). Is there any way to perform this operation?

Many thanks in advance.


ChemAxon fa971619eb

13-03-2007 10:26:43

Yes, you can do this, but you need a Standardizer to do it.

You should define a standardizer for your JChem table and include the clear stereo action in its definition (you should also have aromatize and Remove Explicit Hydrogens - see the screen shot).

Then when you import into that table the stereo duplicates are detected and not imported (see screen shot).

This way you end up with just the non-duplicate structures. The one you have is the first one that was found, which may be chiral (see screen shot).

If you want all structures to have the stereochemistry removed prior to import then you should create a standardizer file that includes the clear stereo option and process your file with that prior to importing. See:


If you do this I have found a small bug with the JChem version that is used with IJC1.0.7 - you need to first aromatize the structures before you can clear the stereo (and then you can de-aromatize afterwards). This bug seems to be fixed in the development version of JChem so this work around will not be needed in future.

Note: to do any of this you will need a Standardizer license.

User 2d31d11602

13-03-2007 13:47:48

Thanks a lot. It works perfectly. Still one problem: when I cut and paste from structure column to do a substructure search on the whole table, I have the message "Quey returned no hits", even when I "standardize" the query!

What do you think about this?

Thank you.


ChemAxon fa971619eb

13-03-2007 14:00:03

Not sure. It seems to be working for me with IJC1.0.7 and the small file you provided. I can paste a structure from the grid view to the query and it runs correctly when I do a substructure search.

Which IJC version are you using (what does it say at the top of the Welcome screen)?

The query structure will be standardized automatically. So if you have standardized your JChem table so as to remove the stereochemistry the same will be done to your query.


User 2d31d11602

13-03-2007 15:06:42

I am using the 2.0.0 version. Hereafter some screenshots ...


ChemAxon fa971619eb

13-03-2007 15:50:13

This seems to be working for me in 2.0.

Did you remember to add the standardizer actions for aromatize and remove explicit hydrogens, as well as the clear stereo action?

The aromatize and remove explicit hydrogens actions are the default standardization, and without these searches for aromatic structures (such as the one in your screen shot) will give inconsistent results (depending on how the query is drawn).


User 2d31d11602

13-03-2007 16:23:25

Tim, I found the error when taking a screenshot of the standardization I applied. I was adding the explicit H instead of removing them!! :-\ SSS is now working and this did not change the number of removed molecules.

Thank you very much for your precious help.


ChemAxon fa971619eb

13-03-2007 16:28:37


I was just in the process of writing a response to say that I was baffled because it seemed to be working for me.