Decimal separator & thousand sep. - not system settings?

User 9df74a15a4

07-11-2014 11:02:25

In some previous post there was similar question, but it doesn't answer my problem (I think?) -

My numbers are in InstantJChem in the formate

1 000,00 but I want (well, need) 1000.00

despite the system having a dot defined. Are there any recently new settings in IJChem to change this?

I also removed the space (though after having imported to the db), yet it is still displayed as space and exported with a space, also the comma is kept instead of a dot. Based on this it can't be the system settings?

One of the simple reasons why I want a different formate is that excel can't handle the exported numbers otherwise. No matter what setting I try in excel, it won't recognize 1 000 as a number. I tried replacing the space, but it doesn't seem to be handled as regular space. I am not good at RegEx otherwise I could probably try and search/replace via some form a generic whitespace in another program. Though this doesn't feel very productive.

Am using 14.10.13 64bit on Win 7 64bit, Swedish locale but changed the decimal to dot (and removed the display of thousands to setting without any space inbetween).


User 9df74a15a4

10-11-2014 08:20:52

may I bump this post?

ChemAxon 2bdd02d1e5

12-11-2014 14:44:28

There are no new related setting in IJC. But you can change it by the old fashioned way. There is a startup option (add it to etc/instantjchem.conf). This will force the app to use english locale and dot as decimal separator:



User 9df74a15a4

13-11-2014 09:21:05


So, seeing this - comma instead of dot - , is that because it is a db imported with different language settings? (see attachment pic)

System settings are dot for decimal separator *and* I used the addition to the conf file as you suggested.

ChemAxon 26d92e5dcd

14-11-2014 10:59:23


I have investigated the problem. First of all, the option that Filip suggested should override the system defaults, but I have confirmed that it does not. This is a bug. 

It should be possible to override the system locale by that option.

But what works, is the following:


But also do not forget that in must be in the instantjchem.conf in the "default options" section, so you would have to have something similar like this:

default_options="--branding instantjchem -J-Xms48m -J-XX:MaxPermSize=196m -J-Dderby.system.home=derby -J-Dnetbeans.logger.console=true -J-ea -J-Dorg.netbeans.ProxyClassLoader.level=1000 -J-DuseGtk=false -J-Duser.language=en"

 I hope this helps


User 9df74a15a4

14-11-2014 13:46:18

Thanks, I will try this