out of memory

User 6fe3d4c2db

15-10-2014 11:55:08

Hi all,

I upgraded from 6.3.3 to give the new version a try. Now I have problems with structure search:

" main table" could not fit into structure cache (out of memory).

I already set the memory settings under Tools->Options-> Miscellaneous->other
settings to maximum.

The old version worked with the same size of data! Any hints?

Best Regards


ChemAxon 26d92e5dcd

15-10-2014 12:01:02

Dear Andreas,

could you please provide us with the log file when the problem occurs? This will help us diagnose what the possible problem is. How to get the log file you can find here

All the best


User 6fe3d4c2db

15-10-2014 13:11:15

Dear David,

the problem seems now solved. To get a "clean" session log file I
restarted the InstantJChem client a few times and checked for the error. After
a second try the structure search works again. For me it looks like the cache
parameters are also somewhere cached.....

I tried this on a second client with the same results: Error -> adapt
memory settings -> restart -> new session with error -> restart ->
correct search.

I have more clients to check.....



User 6fe3d4c2db

16-10-2014 09:35:14

Hallo David,

the problem is still there. This morning (fresh booted Windows) InstantJchem gives the out of memory error when a colleage started a structure search. The "work-around" on this client was to restart InstantJchem twice and the error disappears. However on my machine today the error do not disappear after restarting IJC....
Yesterday it worked. Since yesterday there was only a windows reboot (caused by patchday).

The IJC-logfiile is attached

Best regards


ChemAxon 26d92e5dcd

22-10-2014 11:13:44

Dear Andreas,

I checked the log file and unfortunately I could not find any helpful information for now. What exactly is your settings for the maximum memory? I can see that you are on Windows 7 with 32-bit Java 7. The recommended minimal settings is 512 MB.

I would suggest trying to set this in the the instantjchem.conf file as a default option. 

You can find the file in the installation directory (Program Files/ChemAxon/InstantJChem/etc) and you should change the following:

default_options="--branding instantjchem -J-Xms48m -J-XX:MaxPermSize=196m -J-Dderby.system.home=derby -J-Dnetbeans.logger.console=true -J-ea -J-Dorg.netbeans.ProxyClassLoader.level=1000 -J-DuseGtk=false -J-Dorg.netbeans.core.TimeableEventQueue.report=86400000"


default_options="--branding instantjchem -J-Xms48m -J-Xmx512m -J-XX:MaxPermSize=196m -J-Dderby.system.home=derby -J-Dnetbeans.logger.console=true -J-ea -J-Dorg.netbeans.ProxyClassLoader.level=1000 -J-DuseGtk=false -J-Dorg.netbeans.core.TimeableEventQueue.report=86400000"

where I have highlighted for you in red the option that was added. It is possible that by setting the maximum memory settings is lost after a reboot and then as IJC by default has no set maximum memory and is using Java's virtual machine heurestic algorithm to allocate memory.

Could you try it with this once more and see if this works for you?