Are IJC version backward compatible?

User cbd52052a1

16-07-2014 19:00:19

I was wondering if IJC versions are backward compatible. I am attempting to email the ZIP backup copy of a local database and the party I emailed it to cannot open the zip in their version of IJC. They are working with an older version of IJC but have stated they aren't interested in updating to the newest "unstable" version.


The error message when attempting to open the ZIP backup in IJC says, "Not a valid Local DB Backup ZIP file". I can unzip and open the backed up file just fine on my version of IJC (5.12.4). Both me and the other party are using Windows operating systems.


Is the older version of IJC the issue or is this caused by another issue?


Thanks for any help you can give!

ChemAxon 26d92e5dcd

17-07-2014 07:13:34

Hello and welcome to the ChemAxon forum,

I am sorry, but there is no backwards compatibility support among major IJC versions. If you are using IJC 5.12.4 (which is by the way not the newest), you should be able to have compatibility with any other 5.12.x release. But if the other party is using even older IJC version, then there will be no compatibility support. This has to do with regeneration of JChem tables in the database with every major release. Please see for more details on which version has this change. 

Basically, if the IJC versions differ in their major version, the issue is the version. If, however, the IJC versions differ only in their minor version, the issue could be theoretically somewhere else.


In any case, if your license permits, I would recommend updating to the newer version. I would recommend IJC 6.3.1, or soon to be released IJC 6.3.2. We have also a newer IJC 14.7.7 (updated weekly), which is temporarily less stable, but 6.3.1 or future 6.3.2 are stable releases. 

I hope this explains the situation



User cbd52052a1

21-07-2014 18:17:09

Hi David,


Thank you for the quick response. I understand what you are saying and that is very helpful.

If IJC tables and databases aren't compatible between major versions at all, then how are you supposed to restore a ZIP file backup of your database from the older IJC version in the newer IJC version in an instance where data is lost during an update? I have a separate computer updated to the 6.3.1 IJC version and I am attempting to restore the ZIP backups from my other computer's 5.12.4 IJC version. When I do, I get that error "Not a valid Local DB Backup ZIP File".

The only method I can think of to work around this is exporting all of the tables into Excel for JChem, which seems like a hassle. Is there another way to ensure my backups will work on a newer version in a case of data loss?



ChemAxon 26d92e5dcd

22-07-2014 13:59:04

Hi Elli,


the approach that you described would be the correct one. I have tested this with Derby DB and with the versions you describe and it was working without any glitch. I have used the following:

  1. Create the ZIP by right-clicking the schema -> Backup schema to ZIP file...

  2. Open IJC 6.3.1, create an empty Project

  3. Select File -> Restore Schema from ZIP backup...

  4. Open the Schema and agree with all the updating dialogs:

    • Upgrade Local Database (10.8 -> 10.10)

    • Upgrade IJC Schema (5.12.0 -> 6.3.0)

    • JChem Tables upgrade

    • Refresh IJC Metadata

How did you create the ZIP backups? With IJC, or manually? If you just zipped the project folder manually, it will not work as it would give you the same error you describe. 

I would suggest to try the steps if you have done the process differently.



User cbd52052a1

23-07-2014 17:36:24

Hi David,

The zip files are all files that I zipped by right clicking on the schema and selecting "Backup schema to ZIP file". When I attempt to restore ZIP files from an older version I still get there error "Not a valid Local DB Backup ZIP file.". When doing this I used the exact same process as the one you described except when I open the zipped schema I get this error message instead of the option to update the tables to the newer version of IJC.

It is worth noting that this process works perfectly fine if I use the zipped schemas that were made from the same version.

Any ideas why that would be?



User cbd52052a1

23-07-2014 17:39:14

Hi David,

Another item worth noting is that while both my operating systems are Windows, one is Windows 7 and the other is Windows XP.


Could this be the source of the issue?



ChemAxon 26d92e5dcd

23-07-2014 21:06:22

Dear Elli,


it should not matter what operating system you are using. I created a ZIP backup and corrupted it. I unzipped the file and changed the content of .config/localdb.ijs XML file which defines the schema's connection to the database. Then zipped all the files again and got the same error you describe.


Unfortunately when the error appears, there is no other info that could be useful for diagnostics. But thanks to this, I might have a workaround that could work for you. 


Try the following:

  1. Go to the folder with your project (for example YOURHOMEDIR\IJCProjects\projectName

  2. On the other computer where you have IJC 6.3.1, create a folder in wherever you store your projects (probably the same default location in .../IJCProjecs folder

  3. Transfer all the files from step 1 to the folder in step 2

  4. Open IJC 6.3.1 and go to File -> Open Project and navigate to the folder from step 2 and open it as you would do with any other project and follow with update prompts as mentioned in my previous post

In step 3 you can zip the files, but you have to make sure that the content of the target folder is exactly the same as in the source project folder. It should have a structure as seen on the screenshot attached.


Please let me know if it works for you. 



User cbd52052a1

23-07-2014 22:46:37

Hi David,


Yes, that did work for me, thankfully!

Thank you very much for helping me.