Unable to import more than 8 digit in decimal integer field.

User 07206ada1e

10-12-2013 10:36:34

My .SDF file contains energy values in Hartrees (8-12 digits). When importing this values in decimal integer format JChem cuts them to 8 digits. I've tried DECIMAL, NUMERIC, REAL etc. options with no result. Importing in text format works properly, but any converting to integer format cuts values again.

Also JChem groups digits in 123, 456.7800 format, while I prefer 123 456. 7800  without comma. I cant find any grouping option except true/false.

JChem 6.1.3 32-bit

Win& 64-bit

ChemAxon 2bdd02d1e5

11-12-2013 23:10:29

Yes you right. If decimal format is chosen, numbers are imported completely wrong. I could import 10 digit integers successfully. IJC unfortunately can't work with integers bigger than 10 digits. Bigger's were wrongly identified as decimals :(

With regards of displayed decimal number format. The decimal separator and thousand separator are not customisable. There are recognised from the locale which is used in Java. This locale can be changed when the application starts by passing a parameter to Java Virtual Machine.

I.e. this parameter "-J-Duser.language=cs" will change the numbers to be like "1 982 234,34".

The parameter should be put to instantjchem.conf file. Please read http://www.chemaxon.com/instantjchem/ijc_latest/docs/admin/startup_options.html 

Thanks for telling us your issue. We'll look how we can make big integers work.