pKa training gives empty pKaReg

User 2d3586be8f

09-02-2010 22:59:46

I read your step by step instructions on how to train pKa's and they all seemed reasonable. Unfortunately, when I ran the command:

cxcalc -T pka -t pka1 pka_train.sdf

the command always runs for 1-2 seconds, completes without any error or warning messages, but the pKaReg directory, although created, is always empty (no files; no data).

Is there anything obvious that I'm doing wrong? I'm attaching the SDF file used in the above calculation, plus a second file with protons stripped (also fails).

Note that the non-training command

cxcalc pka pka_train.sdf

works fine.

ChemAxon e08c317633

15-02-2010 09:21:54

Please post here the output of

java -version



User 2d3586be8f

25-02-2010 15:58:21

Here's the output from the windows box that I tried:

C:\>java -version
java version "1.4.2_03"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_03-b02)
Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode)


I also tried it on a linux box:

kumgmw02 7% java -version
java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20070626 (Red Hat 4.1.2-14)

Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO


I'll try installing Sun Java on the latter, but I would like to know your suggestions on the Windows box.

ChemAxon e08c317633

25-02-2010 16:17:33

Please see our System Requirements:

- Java distributed by Sun (or Apple's Mac OS X built-in Java)
- Java version 1.5
- For 64bit version of MS-Windows systems, we recommend the 32bit version of Java, since currently Marvin Object copy and IUPAC inchi import/export are supported only in 32bit systems.

You should install a newer JRE (1.5, or above) on your Windows box.


User 2d3586be8f

25-02-2010 20:46:18

Thank you for the quick response Zsolt!


I installed newer versions of java:


C:\Program Files\ChemAxon\MarvinBeans\bin\pKaReg>java -version

java version "1.5.0_22"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_22-b03)

Java HotSpot(TM) Client VM (build 1.5.0_22-b03, mixed mode, sharing)



kumgms02 11% java -version

java version "1.6.0_17"

Java(TM) SE Runtime Environment (build 1.6.0_17-b04)

Java HotSpot(TM) Server VM (build 14.3-b01, mixed mode)


But the problem persists on both the Windows and linux boxes.

Note that on the Linux box, I used the JRE packaged with Marvin for developers.  I added the location of the new JRE to $PATH in order to stop it from looking to the Gnu Java first.  On Windows I didn't do any reconfiguration -- just let the wizard do its stsuff.

User 2d3586be8f

08-03-2010 23:18:40

Hi again,

I tried installing on a third machine (another Windows machine, but newer).  I completely wiped out my old version of java (all components) and installed the newest version from Sun.  I then grabbed the Marvin distribution with java bundled (taking no chances) and installed that.  This gives:

C:\>java -version
java version "1.6.0_18"
Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
Java HotSpot(TM) Client VM (build 16.0-b13, mixed mode, sharing)


However the result at this point is the same -- cxcalc runs for 2-3 seconds, but when I look inside pKaReg it's empty.


I notice that a few people have downloaded my sdf files -- if anyone has been able to generate a pKaReg folder based on those structures, could you be so kind as to tar or zip it up and send it to me?

User 851ac690a0

09-03-2010 00:28:44



I also checked your file and I was not able to generate the correction library.

The problem is that only five molecules are included in the "sdf" file.  This is not enough for the teaching method,therefore, an empty pkaReg folder generated.

You would need add more "phenolic acidic" type of molecules into the "sdf" file. This may solve  your problem.

I am working on a more convenient solutionn now.   



User 2d3586be8f

09-03-2010 20:44:56

Thanks, that's very helpful!

Do you know how many we should aim for in order to achieve a satisfactory basis, or is that dependent on the goodness of fit that one is able to achieve with the added molecules?

I have added 8 more phenolic acids to give a total of 13 (see attached), but the training continues to fail.


                        - Gerry

User 851ac690a0

10-03-2010 01:17:20



I have checked your new "sdf" file. It containes some bugs. Please fix the problems and try again to generate the pKaReg directory.

On the attached figures I depicted some problems.

- nitro groups are misstyped

- "pKa"  &  "ID" couples are specified badly  many times. 

The atomic index "ID" value always have to be referenced to one of the  "phenolic OH" group in the molecule. Since its pKa value is given in the "pKa" field.

- sdf file is corrupted.

I highlited the problematic region in your "sdf"  file.  The fixed "sdf" file is shown next to the bad one.



User 2d3586be8f

10-03-2010 20:03:12

Thanks Joszi, and sorry for wasting your time with the last file.

I've corrected the file and checked it over, but it's still not generating a pKaReg -- I attached both an unprotonated and a protonated form.

I appreciate your time thus far, but if you have the chance to take one more look at it I would be grateful.

User 851ac690a0

12-03-2010 02:01:39



Yes, really there is a problem. I fixed it now.  The fixed version (5.3.2) will be available in this month. 



User 2d3586be8f

12-03-2010 14:12:52

super -- thank you very much for your help!