Need help:"Calculation name is not found"

User 984330c09a

09-09-2013 12:47:09

Dear all!

I am quite a newbie in Java & ChemAxon.  What I've tried to do is to integrate BemisMurckoPlugin into cxcalc, following the instructions found here:

However, after the last step, when running: 

cxcalc bemismurcko testmols.sdf

I obtain the following error: "Calculation name is not found"

Other calculations from cxcalc work fine.

What can be the problem?

Thanks in advance for help!


ChemAxon 5fc3e8d7d0

11-09-2013 09:33:15


I think the MarvinBeans/plugins/ file is not set up properly.
The file should look like this: />    
Try to copy file from MarvinBeans/examples/plugin-integration/ to MarvinBeans/plugins/ directory.

Best regards,

User 984330c09a

13-09-2013 11:06:40

Thank you, but the problem seems to be not in file.

If change directory to ./MarvinBeans/bin and launch plugin like:

cxcalc bemismurcko -h

it is possible to get acces to help part of file.

However, the calculation itself doesn't launch, throwing an error:

java.lang.NoClassDefFoundError: BemisMurckoPlugin


Best regards


ChemAxon 5fc3e8d7d0

20-09-2013 14:11:29


Sorry for the late answer. I have checked the tutorial.
The example JAR files (BemisMurckoPlugin.jar) on the website and in the MarvinBeans/examples directory are wrong.
Please, try to use the attached file.

If you are interested in an easier way to integrate third-party calculations, visit the following site: />
Best regards,

User 984330c09a

27-09-2013 05:38:57

Thank you very much indeed for your help!

However, I'm still getting an error, which is Unsupported Class Version Error.

There is JRE v 1.7 installed on my computer. Are there any problems with compatibility?

Best regards,


ChemAxon 5fc3e8d7d0

01-10-2013 09:53:54

Dear Elena,

The previous attached JAR file is compiled using Java 1.7. If your MarvinBeans/bin/java.ini file describes a Java 1.6 location, you get the mentioned exception.
I attached the recompiled JAR (Java 1.6). Try to use it or change the path to your JRE 1.7 location in java.ini file.

Best regards,

User 984330c09a

02-10-2013 19:59:26

Dear Laszlo,

Thank you very much, everything is working now! Changing of .ini file worked for me as well.

Best wishes,